cardDAV & calDAV not found...

Greetings.

I am attempting to sync my phone’s contacts…

Steps taken…

  • Installed DAVDreoid onto phone.
  • Looked up setup tutorial.
  • Followed steps through login.
  • Upon trying to log in, I am met with the error message, “Configuration detection - Couldn’t find CalDAV or CardDav service.” It asks if I want to look at logs or click out via, “OK.”

Expected result…

  • Login to complete and either sync calendar and contacts or present the next step necessary to select them. I can’t tell, extactly, because the error appeared.

This is currently a show-stopper. Thank you very much for reviewing and recommending steps to resolve it.

  • Shadowstreik

What URL did you use?
Did you follow this tutorial?
https://howto.disroot.org/en/nextcloud/sync-with-your-cloud/android/calendars-contacts-and-tasks

Are you using Two Factor Authentication?

EDIT:
I just tested it with test account on my phone and it worked without an issue. I’m also syncing my contacts, tasks, and calendar on my promary account on regular basis. Maybe providing a screenshot would give a hint into what is wrong.

Hi, thank you. Yes, that is the very tutorial that was used. A screen shot would likely not be useful as that very error would be front, center and blocking the login boxes, behind. 2FA has not yet been set up. I’m holding off until being able to sync is working.

Not sure which android version and which davdroid version you’re using, you could try this url:
https://cloud.disroot.org/remote.php/dav

That doesn’t appear to work to nav to.

I’m met with a login pop-up and then once that’s done…


Disroot Cloud

Unauthorized

Technical details
Remote Address: 170.178.173.158
Request ID: BO0ImEMbeF6tvgfQg2CQ
Disroot Cloud – Powered by Nextcloud

I’m using Android 7 and DAVdroid 1.9.8.1-gplay

As far as I know DAVdroid does not produce popups with nextcloud error screens. Can you, start DAVdroid manually (not via nextcloud app) and re-do it?

Also screenshots along the way would help. From our side I can say it all works as expected so it must be some misconfiguration on your end.
Does logging in via browser work?

Logging is in the app. It’s very very long. I’m providing the tail…

==========================================================================
… at at.bitfire.davdroid.ui.setup.DetectConfigurationFragment$ServerConfigurationLoader.loadInBackground(DetectConfigurationFragment.kt:112)
at android.content.AsyncTaskLoader.onLoadInBackground(AsyncTaskLoader.java:312)
at android.content.AsyncTaskLoader$LoadTask.doInBackground(AsyncTaskLoader.java:69)
at android.content.AsyncTaskLoader$LoadTask.doInBackground(AsyncTaskLoader.java:66)
at android.os.AsyncTask$2.call(AsyncTask.java:304)
at java.util.concurrent.FutureTask.run(FutureTask.java:237)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1133)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:607)
at java.lang.Thread.run(Thread.java:761)

SOFTWARE INFORMATION
Package: at.bitfire.davdroid
Version: 1.9.8.1-gplay (197) from Dec 16, 2017
Installed from: com.android.vending
JB Workaround installed: no

CONNECTIVITY (at the moment)
Active connection: WiFi, CONNECTED

CONFIGURATION
Power saving disabled: yes
android.permission.READ_CONTACTS permission: granted
android.permission.WRITE_CONTACTS permission: granted
android.permission.READ_CALENDAR permission: granted
android.permission.WRITE_CALENDAR permission: granted
org.dmfs.permission.READ_TASKS permission: denied
org.dmfs.permission.WRITE_TASKS permission: denied
System-wide synchronization: automatically

SQLITE DUMP
android_metadata
| locale |
| en_US |

services
| _id | accountName | service | principal |

sqlite_sequence
| name | seq |
| services | 4 |
| homesets | 4 |
| collections | 4 |

homesets
| _id | serviceID | url |

collections
| _id | serviceID | type | url | readOnly | forceReadOnly | displayName | description | color | timezone | supportsVEVENT | supportsVTODO | source | sync |

SYSTEM INFORMATION
Android version: 7.0 (NRD90U)
Device: LGE LGLS775 (ph1)

— END DEBUG INFO —

I meant if you can login to cloud with a browser like firefox or something, just to check and verify it works.

Also maybe using lower case letters in your username will help.

Could be :stuck_out_tongue: Please try to login from normal webbrowser on desktop or mobile and go to Calendar or Contacts app, you should certainly see your calendar. Then you could try again to login via DavDroid.

I can log into the cloud via a browser (2FA enabled). The functinality, including calendar, works ok.

Davdroid has been attempted with both the capital and lower-case. Both end in that same pop-up error. :\

PS_ I uploaded and shared the debug log with you via the cloud.

So you do have 2FA enabled.
In that case you need to create app password for davdroid.

Created it. No success. Same error.

PS- Just as an observation, when I created the password… I click ‘Done’ and it disappears. It’s doesn’t end up on anything I can see. I enter the app name, click 'Create…", I copy the password that appears, click ‘Done’ and it disappears. I have OBS, so I can record it happening. Oh, I also use Chromium (not that it means much).

Hokay.

So. I could reproduce your issue. It apears to happen when you type the app password wrong. I checked it few times and the moment I would change the password for the app (misstype it) it would produce 405 “Method not allowed” error. It very missleading as it should say wrong password, but I guess because of 2FA the response from nextcloud is not just simple 403.

As for your question regarding the password. Yes as stated when creating password it will only apear once. The moment you hit “Done” it will be listed in your devices list above. There you can revoke access to it.

So make sure you type the app password correctly, and maybe (if you havent yet) logout and in after enabling 2FA.

Time for the “Eureka!” moment.

Thank you very much for the assistance! It’s working great, now. Now, I just need to find where it resides so I can keep a local copy.

Good morning.

I have my own NextCloud Instance and changed routers, yesterday. While I work on that, I figured I’d sync up to Disroot in the meantime. I ran into the same problem. I also disables 2FA just in case for re-enabling, after. I get that same ‘unable to locate’ error.

Would this be related to the recent issues the NextCloud instance recently had?

It should work fine (works fine for me). The issues we have currently are only causing slowness of the platform.

So you should double check your setup and try to check logs on your instance to see whats happening.

It’s working ok, now. Thank you.