Connecting issues with Thunderbird

Hi there,

when using Thunderbird I often have issues connecting to my disroot account while the webmail service works fine I suspect some settings in my user.js to be responsible for this.

Is there anything known, that a specific setting can cause this?

Part of the config includes the following settings:

user_pref(“network.IDN_show_punycode”, true);
user_pref(“security.cert_pinning.enforcement_level”, 2);
user_pref(“security.ssl3.dhe_rsa_aes_128_sha”, false);
user_pref(“security.ssl3.dhe_rsa_aes_256_sha”, false);
user_pref(“security.ssl3.ecdhe_ecdsa_aes_128_sha”, false);
user_pref(“security.ssl3.ecdhe_ecdsa_aes_256_sha”, false);
user_pref(“security.ssl3.ecdhe_rsa_aes_128_sha”, false);
user_pref(“security.ssl3.ecdhe_rsa_aes_256_sha”, false);
user_pref(“security.ssl3.rsa_aes_128_sha”, false);
user_pref(“security.ssl3.rsa_aes_256_sha”, false);
user_pref(“security.ssl3.rsa_des_ede3_sha”, false);
user_pref(“security.mixed_content.block_active_content”, true);
user_pref(“security.mixed_content.block_display_content”, true);
user_pref(“security.tls.version.min”, 3);
user_pref(“security.ssl.require_safe_negotiation”, true);
user_pref(“security.ssl.treat_unsafe_negotiation_as_broken”, true);

You are rejecting lots of stuff, do you know what these lines do? Try clearing all then adding them one by one.

I would remove those lines which say 256.

These settings deactivate cipher which are considered to be not safe according to the guidelines of the IETF from 2015 and also force Thunderbird to use TLS 1.2. The mixed content settings prevent non encrypted stuff in HTTPS content. The other settings deal with insecure renegotiation and the origin of signature of certificates.

But your suggestion to add them line by line is a good idea!

so what line was causing problems?

Actually none of them – I entered the username including the domain @disroot.org, which caused the server to block connection requests due to the repeating fails. :no_mouth: