DAVx5 fails to add Disroot account

Hello,

I previously set up DAVx5 (aka DAVdroid) on my Android smartphone to sync calendars and contacts with Disroot. This worked fine for a while until a week ago, when syncs failed with DAVx5 connection errors that show up on my phone’s notification pane.

I tried to completely remove my Disroot account from my phone (which also erased any existing contacts and calendars on the phone) and re-add the account from scratch. Unfortunately, when I tried to add a new account (using the “Login with URL and user name” option), it gives me an error saying “Couldn’t find CalDAV or CardDAV service”.

For the “Base URL” I tried https://cloud.disroot.org/, https://cloud.disroot.org/remote.php, and https://cloud.disroot.org/remote.php/dav, but none worked.

For “User name”, I used my Disroot username (without the @disroot.org at the end).

For “Password”, I tried to use my default Disroot password and a generated app password, but they both failed.

What can I do to remedy this problem? Thank you.

Few things:

  1. base url should be https://cloud.disroot.org/ so no need to experiment
  2. You mention app password and normal password which indicates possible mess. Do you use two factor authentication? If so you need to create an app password and put it in the Davx5. If you dont you need to use your disroot password
  3. Please provide us your username so we can check in logs for more details. My wild guess is that your IP is being blocked because of missconfigured app (not neccecarily davx5 but any other you might have even forgotten about). Usually logs reveal that. You can send us a line at support_at_disroot.org for more private follow up on this.
1 Like

Thank you @muppeth:

  1. Base URL: OK, will do.

  2. I do not have two-factor authentication turned on. However, I have always used app passwords (instead of my default Disroot password) so that I can see on my Settings->Security page a history of which clients have connected at what time. Regardless, using my default Disroot password fails anyway.

  3. I have just emailed you my username with the DAVx5 debug log attached.

Please let me know what else I can do to help troubleshoot this pesky problem. Thank you!

Oh one more thing @muppeth: I can still sync contacts/calendar successfully from my other clients such as Thunderbird. Not sure if this information helps.

In case anyone is still following this thread, I couldn’t figure out this problem even with @muppeth’s help, so I wiped then re-installed the OS on my Android device. When I install DAVx5 from scratch, my Disroot contacts/calendar sync worked.

1 Like