MacOS 10.14 How to sync

Hello, I recently upgraded to OSX 10.14 (Mojave) and am not having much success getting my calendar and contacts to sync. The How To page notes under requirements “Apple computer with OSX (10.8 - 10.11.6) installed” – is it entirely impossible to sync under Mojave? If it’s not, I’ll stop banging my head against this wall.

Thanks, all!

ETA: I searched for ‘mac’ in the forums but found almost nothing.

I had mojave on my iMac before I sold it few weeks ago. I had sync set up.

What part is not working?
What url are you trying?

try putting https:// in front of the url

I’ve tried most every variation of obvious tweaks, but I keep getting “Unable to verify account name or password”. I’ve tried every permutation of added disroot.org to my username or not, adding https or not.

One thing did occur to me… I do have 2FA set up – maybe I need to set up an app password?

yes. I had single app passwords set up.

That’s not working either. =[




looks good but the username is wrong or not?
Just the username without @disroot
I know it needs to be https://

I used 2 app specific passwords. One for caldav the other for carddav.
But that was just because I wanted too.

I know I had it working. :frowning:

Try these
https://cloud.disroot.org/remote.php/dav/

So the settings should be like the first screencap? Username is correct as entered.

What is the url for? Should I use that as the server address? (If so, I tried it and it doesn’t work.)

Curiously, I get the “unable to verify account name or password” error message faster than you’d expect a ping. :thinking:

hXXps://cloud.disroot.org
/remote.php/dav/

hXXps://cloud.disroot.org/remote.php/dav/

hXXps://cloud.disroot.org/remote.php/dav

hXXps://cloud.disroot.org
/remote.php/dav

XX = tt - I wanted to deactivate the preview

thats what I was thinking. Try with / and without too. These url parameters are always strange

I can not try myself.

hey I think thats the answer

hXXps://github.com/nextcloud/server/issues/7519#issuecomment-352188027

caldav: hXXps://SERVER/nextcloud/remote.php/dav/calendars/USER/CALENDAR-NAME/
carddav: hXXps://SERVER/nextcloud/remote.php/dav/addressbooks/users/USER/ADDRESSBOOK-NAME/

You convinced me!

Unfortunately, this didn’t work either. :sob: Same error. I tried with /nextcloud/ in the path and without it. It still gives me the entirely too-quick error.



Thanks for your persistence in helping me… even if we haven’t figured this out yet, I appreciate the time you’re spending.

I am not sure if this is right but I need some sort of log file, so try this:

hXXps://manuals.gfi.com/en/kerio/connect/content/os-x/logging-ical-and-addressbook-communication-1296.html

It is fine. It is your time mostly :smiley:
I just give hints

did you get the calendar name right? Try the log file thing. Without it I can not tell what the problem is.

Also create a text file with options you already tried. I lost overview.

I think this is what you are looking for?

com.apple.message.domain: com.apple.AddressBook.accounts.summary
com.apple.message.summarize: YES
com.apple.message.carddav_accounts: 1
com.apple.message.disabled_accounts: 0
com.apple.message.enabled_accounts: 2
com.apple.message.ldap_accounts: 0
com.apple.message.exchange_accounts: 0
com.apple.message.total_accounts: 3
SenderMachUUID: 56E3B4FC-3449-3576-A011-0B56D16BA119

Copied straight from Disroot’s webapp.

I kinda was expecting more errors.
Try to configure it and look at the log. Maybe something more usefull will appear

Interesting. I tried subscribing to my shared calendar by going into iCal and clicking file -> new calendar subscription.

Result:

potentially related logs:

com.apple.message.domain: com.apple.continuity.activity.isresumable
com.apple.message.__source__: SPI
com.apple.message.bundle_id: unknown
com.apple.message.activity_type: unknown
SenderMachUUID: 58A61C75-99B9-3D7B-891E-0236DAFC0C1C

com.apple.message.domain: com.apple.AddressBook.accounts.summary
com.apple.message.summarize: YES
com.apple.message.carddav_accounts: 1
com.apple.message.ldap_accounts: 0
com.apple.message.disabled_accounts: 0
com.apple.message.enabled_accounts: 2
com.apple.message.exchange_accounts: 0
com.apple.message.total_accounts: 3
SenderMachUUID: 4E8B4D21-B707-3321-885E-40CFDCB826A5

com.apple.message.domain: com.apple.calendar.viewAtLaunch
com.apple.message.signature: Monthly
SenderMachUUID: 4E8B4D21-B707-3321-885E-40CFDCB826A5

com.apple.message.domain: com.apple.calendar.account_refresh_2
com.apple.message.__source__: SPI
com.apple.message.result: pass
com.apple.message.signature: success
com.apple.message.signature2: com.apple.account.appleaccount
com.apple.message.summarize: YES
SenderMachUUID: E8B3E7B9-F3BA-3306-8375-DBBEC3074015

com.apple.message.domain: com.apple.assumes.failure
com.apple.message.signature: EE0CDA53-6FF9-3B4E-A571-335A5FF6B6F4:92321
com.apple.message.signature2: 0x89
com.apple.message.signature3: libxpc.dylib
com.apple.message.summarize: YES
SenderMachUUID: E2595CD9-EE91-30AF-81D5-90D0FA46B4DF

Already tried to process this operation before
OSActivityID: 0x8000000000048962
com.apple.message.domain: com.apple.calendar.operation_process_error
com.apple.message.summarize: YES
SenderMachUUID: E8B3E7B9-F3BA-3306-8375-DBBEC3074015

com.apple.message.domain: com.apple.calendar.account_refresh_2
com.apple.message.__source__: SPI
com.apple.message.result: pass
com.apple.message.signature: success
com.apple.message.signature2: com.apple.account.appleaccount
com.apple.message.summarize: YES
SenderMachUUID: E8B3E7B9-F3BA-3306-8375-DBBEC3074015

com.apple.message.domain: com.apple.calendar.account_refresh_2
com.apple.message.__source__: SPI
com.apple.message.result: pass
com.apple.message.signature: success
com.apple.message.signature2: com.apple.account.appleaccount
com.apple.message.summarize: YES
SenderMachUUID: E8B3E7B9-F3BA-3306-8375-DBBEC3074015

com.apple.message.domain: com.apple.BezelServices.ALSStatsActivityFiltered
com.apple.message.__source__: SPI
com.apple.message.value: 1900
com.apple.message.value2: 1300
SenderMachUUID: 881C0C29-51B3-35EF-A42B-64AE1D947F61

OSActivityID: 0x8000000000048964
com.apple.message.domain: com.apple.nlp.textchecking5
com.apple.message.__source__: SPI
com.apple.message.signature: TypingInfo
com.apple.message.summarize: YES
com.apple.message.value: 23
com.apple.message.value2: 40
com.apple.message.value3: 4
com.apple.message.value4: 2
com.apple.message.value5: 0
SenderMachUUID: 4E8B4D21-B707-3321-885E-40CFDCB826A5


com.apple.message.domain: com.apple.BezelServices.ALSStats
com.apple.message.__source__: SPI
com.apple.message.value: 2000
com.apple.message.value2: 0
com.apple.message.value3: 1300
com.apple.message.value4: 0
SenderMachUUID: 881C0C29-51B3-35EF-A42B-64AE1D947F61

com.apple.message.domain: com.apple.assumes.failure
com.apple.message.signature: EE0CDA53-6FF9-3B4E-A571-335A5FF6B6F4:92321
com.apple.message.signature2: 0x89
com.apple.message.signature3: libxpc.dylib
com.apple.message.summarize: YES
SenderMachUUID: 9A390B05-0D03-36F9-866A-E0A7B5C32047