SearX instance can't be added as Firefox default search engine

Hi there, it appears that the search.disroot.org instance of SearX has a missing configuration, as described here:
github.com/asciimoo/searx/issues/1849
It should appear as an option in the three horizontal dots menu in Firefox, as shown in this screenshot from another SearX instance:


Thanks for your excellent service!

@rahim123 Thanks for reporting (next time it’s enough to do it on taiga, less places to answer and folloow up). Also thanks a lot for doing research on your own, made the fix a breeze.

It should now show you the option to add to firefox.

Hi @muppeth, thanks a lot for the fast action, and sorry for the double-posting.
Unfortunately Firefox still does not show the option to add the Disroot SearX instance as an engine. I tried to force-reload the page, but still no dice. Any more tips?

Are you sure you dont have searx instance in your search engines already?

I think I know what the issue is. Our instance is just called searx so if there is another one with the same name you will get issues. I changed the name to “Disroot seax” so it should work.

1 Like

Awesome, that did the trick! Thanks so much for the fast fix.
So yes, that was the problem, I had the searx.info instance added, which is just named searx.
Cheers!

Quick question: if/when a SearX source engine is throwing an error, (constant timeouts, asking for CAPTCHA or whatever), do you want any kind of user feedback, or would that be too much noise? And if so, what’s the least annoying way for us to notify you?

All admins use searx as our main and only search engine so we are well aware when google blocks us :slight_smile:
But there is not much we can do apart form tweaking filtering fomr bots etc.