[SOLVED] Disroot Search always opens links in new tabs

So I have benn using disroot’s searx instance for some weeks, and I think it is great, but there is something that bothers me: links are always opened to new browser tabs. Why?

I did set “Results on new tabs” to No, but it just doesn’t care. Is this a bug or a feature?

I have tried another searx instances and this option works properly.

Anyone that knows what is happening (to me)? Thank you

Don’t think this is issue on our side. Just checked (though I always open results in new tabs), and here is the interesting twist:

  • Firefox - Opens in new tab despite the setting
  • Chromium - Opens in the same tab is set to do such thing.

So could be firefox settings? Dunno. I will check on another machine with default settings (both browser and searx), but it could very well be firefox setting.

Interesting, I have just tried and on another machine links are opened on current tab (I didn’t try changing settings) using Chromium, Brave, Firefox and Waterfox.

This machine is a x200 on Gentoo, the browsers I tried with are Palemoon and Firefox, which still don’t care about the links on new tabs settings.

Edit: on the other machine, on palemoon it works as expected, so it might be a problem with this machine.

Now I unticked this setting and now links are openned on new windows. It was ticked previously.

Edit: The issue is not solved, this was just a debug message, just in case.

I solved it deleting the cache for search.disroot.org