[Solved] - Notes App on Android is not connecting to server

Hi,
I followed the instructions for using notes on Android here:
https://forum.disroot.org/t/cloud-howto-use-notes-in-android/754?u=nobody

When I try to connect I receive the following error:
Invalid login: URL/server has errors

Is this perhaps a temporary error?

Thanks

Hi @nobody
I just checked and everything works fine here. I even removed and re-installed the app on my phone. Could you provide more info? screenshots etc?

Hi @muppeth

thanks for your quick response.

I just removed the app “Notes” as well and re-installed from f-droid but the issue persists.
I use Android 4.4.2 (nothing newer available for this phone).

The server address is the same as in the tutorial and seems to be correct.

Any ideas?

Seems to me the url you’re typing is wrong. I can only reproduce your error when I misspell it. check that it is https://cloud.disroot.org without spaces etc.

I thought also that I may have mistyped it but it’s even OK-ayed by the server:

It’s driving me crazy.

I even tried to create an App password, but no success.

Weird indeed. I’m looking for someone with such ancient android to test it out. I see you’re also running tor, so i’m guessing you also run other privacy apps like xprivacy etc. Try disabling them to check if the problem is not caused by one of the settings.
As soon as i find some test device i’ll let you know of my findings.

Is nextcloud android client working for you?

Yes, ancient that is :wink:
I am planning to install a mod and have more options, but not for now.

I only run tor, nothing else.
I will play around a bit and see if I succeed.

Thanks for looking into this.

A friend of mine just tested it on android 4.2.2 and it works just fine.

Also please let me know if nextcloud client for android works for you or not.
https://f-droid.org/repository/browse/?fdfilter=nextcloud&fdid=com.nextcloud.client

Just got another feedback from a friend using 4.4.2 so it seems like its an issue on your end. Please PM me so we could look at your issue closer and maybe find out why it doesnt work for you.
Cheers!

Thanks for you efforts, very much appreciated.

I will email you directly.

I managed to fix it!

I simply deleted the “Notes” folder from the Nextcloud files.
This folder is apparently what the “Notes App” is trying to create when one connects to the server through the app for the first time.
My “Notes” folder existed already and somehow this caused the server error: Invalid login: URL/server has errors.

Perhaps, this will be helpful to others someday.

2 Likes

Nice to know

Ah. Good to hear you found the way to fix it.
I wonder why it was trying to create the folder in the first place. I havent have such issue before.

thanks to nobody (haha ;)) I managed to fix that same issue by deleting my notes folder on nextcloud