SSL Certificate expired

I cannot access mailbox with imap.

Thunderbird says
“This site attempts to identifiy itself with invalid information.
Outdated Information”.


Certificate for disroot.org

Subject Name
Common Name disroot.org

Issuer Name
Country US
Organization Let’s Encrypt
Common Name R3

Validity
Not Before 2021/5/12 6:53:42 (Asia/Tokyo)
Not After 2021/8/10 6:53:42 (Asia/Tokyo)

FYI
I can’t access the webmail on mail.disroot.org (“can’t connect to server”) but through https://cloud.disroot.org/apps/rainloop/, I can.

Weird.

The same thing is happening to me. I really need this fixed.

Sorry we had some issue with ssl certificate that has not been properly renewed on mail server although the new certificate was already present for all web services. Sorry for the disruption. Th eservice should be working well again

Thank you! It did start working again! Wow, amazing response time.

Thanks though considering the issue occured 6 hours ago, not so fast hahahaha… On our defence I can say, we were all sleeping (all admins are eu based).

Well, it was way better than most companies that I have worked with. Another reason I have used disroot for all of these years.

1 Like

Thank you very much. I was getting the same error “Can’t connect to server” starting around 2021-08-09 UTC, now fixed :slight_smile: For a while, I thought you people stopped being Tor-friendly.

Also, I thought I could use this forum with the same l/p as mail.disroot.org but I had to create a separate account for posting this… which is okay but was slightly counter intuitive.