Webdav support

Hi all,
Again just wanna show my appreciation for the hard work in keeping this great service running. Much love.

I’m wondering if i could get some help in setting up a webdav app to the nextcloud server.
I’m using cryptomator to encrypt files client side and upload them to the cloud, but dont seem to know the web address for the webdav to link it to.
As you may well have guessed, im not very educated on all this stuff.

Cheers in advance

Hi there,

According to nextcloud documentation at: https://docs.nextcloud.com/server/12/user_manual/files/access_webdav.html

this is what you would have to use as url:
webdav://cloud.disroot.org/remote.php/dav/files/YOUR_USERNAME
Of course you should replace YOUR_USERNAME with well, your username :slight_smile:
I havent tried it myself so let us know if it worked. Also consider sharing a small howto on cryptomator and nextcloud so others could use it too. You can just start a thread in the Tutorial section in the forum (no pressure though :P) .

Thanks for the kind word.

Hi!

In case some faces the same problem.

When connecting with Cryptomator it said “Wront username and/or password”. But I didn’t remember that I had activated TOTP (2FA).

I solved by creating a new app password down, in Devices and Sessions. Then I use that username and password to log in into Cryptomator (with the URL that says on the post above)

Hope it helps somebody! :slight_smile:

libertus @ 2019-09-08 17:32 UTC:

In Cryptomator for iOS says “Wront username and/or password”, and in macOS “There was a problem connecting with the server. Contact the admin.”

What address are you using to connect to webdav, it should be in this
format: https://cloud.disroot.org/remote.php/webdav/

Read the docs here:
https://docs.nextcloud.com/server/16/user_manual/files/access_webdav.html

@muppeth the url displayed under cloud.disroot.org > files > settings
(one at bottom left) points to a dead link.

··· -- Lugubris

@lugubris you mean this link? https://cloud.disroot.org/remote.php/webdav/

muppeth @ 2019-09-10 08:39 UTC:

@lugubris you mean this link? https://cloud.disroot.org/remote.php/webdav/

No, this one: https://docs.nextcloud.com/server/16/go.php?to=user-webdav

Looks like it was some error from nextcloud’s side, it is working now.

··· -- Lugubris

Hi Guys,
@muppeth Im havinf similar issue logging in to https://cloud.disroot.org. Appreciate if you could guide me… Also noticed my totp used for mail.disroot.org is not accepted for cloud.disroot.org

thanks

@pacbe yes both 2FA are seperate.

Can you explain what your issue is? If the above I think its quite clearly explained already.